What are the system requirements?

Geometry Pad can run on the following platforms:
– Mac with Mac OS X 10.6 or older.
– iPad 1 with iOS 5.1 and older.
– Android tablets and phones running Android 4.0 and older. Some small screen phones are not supported.
– We also support Amazon Kindle Fire tablets.

Please log in to rate this.
0 people found this helpful.


Category: General

← What are the system requirements?